Error: RecipNotFound

Dec 15, 2014 at 4:57 PM
Edited Dec 16, 2014 at 2:17 PM
I have attempted to use the CatchAllAgent with Exchange Server 2010 SP3, but without any luck. Every time I have attempted to send a mail, using SMTP, from an external mail server, I receive an error reply, indicating that the specified mail address wasn't found (#< #5.1.1 smtp;550 5.1.1 RESOLVER.ADR.RecipNotFound; not found> #SMTP#).

I added some logging entries to the code, to make sure that the code gets executed by the Exchange Server and have verified that this it gets started, but the catch all handler never gets invoked.

I can see this by seeing that the CatchAllFactory.CreateAgent gets called, but the CatchAllAgent.RcptToHandler method never gets called.

I tried different agent priorities (Including 1 and 10) as well as the recommended priority (RegExCatchAll agent right before the Recipient Filter Agent ), but unfortunately with no success in any attempts.

My current configuration looks like this:
Connection Filtering Agent                         True            1
Content Filter Agent                               True            2
Sender Id Agent                                    True            3
RegExCatchAll Agent                                True            4
Sender Filter Agent                                True            5
Recipient Filter Agent                             True            6
Protocol Analysis Agent                            True            7
Transport Rule Agent                               True            8
Text Messaging Routing Agent                       True            9
Text Messaging Delivery Agent                      True            10
Any ideas what I'm doing wrong?