Error executing "install-TransportAgent" - Invalid configuration

Jan 7, 2009 at 9:07 PM
Good day,

I am having troubles to install the TransportAgent like you subscribed in your ReadMe file and from the website http://dnn.ebsfaq.com/Exchange2007/Edge/CatchallTransportAgent/tabid/1208/Default.aspx wich explains wich additional screenshots.

When i exactly enter the syntax you describe in your ReadMe i get the following error:
Install-TransportAgent : Invalid agent configuration in file 'C:\Program Files\
Microsoft\Exchange Server\TransportRoles\Shared\agents.config'.
Op regel:1 tekens:23
+ install-transportagent <<<< -Name "CatchAll Agent" -TransportAgentFactory:Ca
tchAll.CatchAllFactory -AssemblyPath:"C:\catchallagent\CatchAllAgent.dll"

It is a Windows 2008 Small Business Server wich uses HUB transport.

Can you help me to troubleshoot this problem
Coordinator
Jan 24, 2009 at 6:42 PM

Can you send me the agents.config file? It looks there is an error in that file. (That's weird, since if this file is corrpted, the Transport service should not be able to start.)

-Wilbert
Feb 20, 2009 at 8:55 AM
Hi Wilbert, I'm getting the same error on another Small Business Server 2008:

Install-TransportAgent : Invalid agent configuration in file 'C:\Program Files\
Microsoft\Exchange Server\TransportRoles\Shared\agents.config'.
At line:1 char:23
+ install-transportagent  <<<< -Name "CatchAll Agent" -TransportAgentFactory:Ca
tchAll.CatchAllFactory -AssemblyPath:"C:\catchallagent\CatchAllAgent.dll"

I've uploaded the file referenced to my site:

http://eklaus.co.uk/agents.rar

Would love to get this working, so any help much appreciated.

Nick





Coordinator
Mar 1, 2009 at 12:02 AM
I just posted about this issue and the solution.