Multiple Domains using 'catchall'

Oct 31, 2011 at 1:51 PM

Hi, Can anyone assist please? I have the catchall agent installed and working on Exchange 2007. However I now need to include two additional Domains as I have added these to the Exchange server itself. Can someone point me in the right direction in terms of syntax please.

Coordinator
Nov 2, 2011 at 2:49 AM

Hello,

The following website shows an example: http://www.petri.co.il/setting-up-a-catchall-mailbox-in-exchange-2007.htm

-Wilbert

Nov 2, 2011 at 11:34 AM

Hi Wilbert,

Many thanks for the link, I have looked here and although it states that you can create for multiple domains it does not supply syntax to do this. here is a copy of what I have in my config.xml file:

<config>
  <domain name="mydomain1.co.uk" address="catchall@mydomain1.co.uk" />
  <domain name="mydomain2.co.uk" address="catchall@mydomain2.co.uk" />
  <domain name="mydomain3.co.uk" address="catchall@mydomain3.co.uk" />
  <domain name="mydomain.co.uk" address="admin@mydomain.co.uk" />
</config>

Should this work or do I have syntax incorrect?

Many Thanks

Rob

Coordinator
Nov 2, 2011 at 7:48 PM

Rob,

This should work.

Wilbert

Sent from my Windows Phone

From: rob1210
Sent: 11/2/2011 4:34 AM
To: wilbertdg@hotmail.com
Subject: Re: Multiple Domains using 'catchall' [catchallagent:277769]

From: rob1210

Hi Wilbert,

Many thanks for the link, I have looked here and although it states that you can create for multiple domains it does not supply syntax to do this. here is a copy of what I have in my config.xml file:

<config>
<domain name="mydomain1.co.uk" address="catchall@mydomain1.co.uk" />
<domain name="mydomain2.co.uk" address="catchall@mydomain2.co.uk" />
<domain name="mydomain3.co.uk" address="catchall@mydomain3.co.uk" />
<domain name="mydomain.co.uk" address="admin@mydomain.co.uk" />
</config>

Should this work or do I have syntax incorrect?

Many Thanks

Rob

Nov 3, 2011 at 10:14 AM

Hi Wilbert,

I set this yesterday and today it is still not working the mydomain1 is still working ok but the other domains are not. Should I have to restart anything for this config to take effect?

Thanks

Rob

Coordinator
Nov 3, 2011 at 2:56 PM

please try with a restart. If that doesn't work you must have edited the wrong file.

Sent from my Windows Phone

From: rob1210
Sent: 11/3/2011 3:14 AM
To: wilbertdg@hotmail.com
Subject: Re: Multiple Domains using 'catchall' [catchallagent:277769]

From: rob1210

Hi Wilbert,

I set this yesterday and today it is still not working the mydomain1 is still working ok but the other domains are not. Should I have to restart anything for this config to take effect?

Thanks

Rob