Exchange 2010 Hosting Mode

Jul 7, 2011 at 1:15 PM

We deployed the agent in an Exchange 2010 SP1 hosting mode/multi-tenancy installation and everything works fine except one major issue. All incoming e-mails for the domains specified are sent to the catch-all address not only incorrect addresses.

I assume it has to do with the address book seggregation. Unfortunately the SDK documentation does not provide any information on how to handle a hosting environment. Can anyone point me in the right direction?

 

Thank you

Sascha

Coordinator
Jul 8, 2011 at 4:51 PM

You are using this in a hosted environment ... The addressbook isn't scoped correctly to work well in a hosted environment, where organizations are all put in their own container.

It would need some code changes to support that.

Sent from my Windows Phone

From: sstops
Sent: Thursday, July 07, 2011 5:15 AM
To: wilbertdg@hotmail.com
Subject: Exchange 2010 Hosting Mode [catchallagent:264243]

From: sstops

We deployed the agent in an Exchange 2010 SP1 hosting mode/multi-tenancy installation and everything works fine except one major issue. All incoming e-mails for the domains specified are sent to the catch-all address not only incorrect addresses.

I assume it has to do with the address book seggregation. Unfortunately the SDK documentation does not provide any information on how to handle a hosting environment. Can anyone point me in the right direction?

Thank you

Sascha

Dec 12, 2011 at 12:02 PM

We are having the same issue in a hosted Exchange 2010 environment.

Anybody succesfully managed to alter the code so it works in Exchange 2010 multi-tenant?

Any help is greatly appreciated!

Regards,

Roald