Need help!! Sbs 2008 and Exchange 2007

May 19, 2010 at 1:16 PM
Edited May 19, 2010 at 1:22 PM
Well we are having a nightmare day!! One of our sites, which is supposed to be very redundant has about 8 internet lines going in, and someone poured petrol over the exchange box and set fire to it! Guess they wanted to destroy the phones so the alarms wouldnt ring the police when they broke in! So no email at this site! :( We have re-directed to another server by swift changing of MX records!! but this site doesnt have all the email addresses etc of the other site.. So i have added the accepted domains in, tried installing your catchall agent! :) looks nifty and fairly straightforward... We need all of the other sites emails say domain1.com being forwarded to one email address which should happen fine. We arent getting any of this occuring!! The agent is installed as per instructions --- Here is our config domain name=*@ma----nel.co.uk" address="catch@pr-ood.co.uk domain name=*@cu---rs.co.uk" address="catch@pr-od.co.uk Ive tried it without stars and still nothing, this email address exists and i can send to and from it fine! Ive tried adding the logging on and still cant see where the traces.log file is or if its adding it somewhere else?? transports agents as below Can anyone help?? Im desperate!! at the mo, ive got all the emails being bounced as i cant even accept them all by adding a *@...com email address to the catchall email! So im having to watch the traffic queue and quickly add that email address into the catch all Thanks Martyn [PS] C:\Windows\System32>get-transportagent Identity Enabled Prio -------- ------- ---- PmE12Transport True 1 Transport Rule Agent True 2 Journaling Agent True 3 AD RMS Prelicensing Agent False 4 Connection Filtering Agent True 5 Content Filter Agent True 6 Sender Id Agent True 7 Sender Filter Agent True 8 Protocol Analysis Agent True 9 PmE12Protocol True 10 CatchAll Agent True 11 Recipient Filter Agent True 12
May 19, 2010 at 1:20 PM
dont ask me why the above is all in a big block! i dont see it like that till i hit post
Coordinator
May 21, 2010 at 7:10 PM

Can you post the configuration file? Or send it to me by email? Are there any evet logs that execution of this agent fails? Did you try the tracing steps, lsited in the README file?

May 24, 2010 at 1:21 PM

Willbertdg

config file as below, the emails need to catch everything from two domains and forward them through to the specified email address, do i need to add these domains in to the accepted domain on the exchange console? Or will this not be required, i have tried both ways.

tried to setup the logging, and cannot find where the log file goes to, or if its actually doing something!

Much Appreciated!

Martyn

<config>
  <domain name="*@---el.co.uk" address="catch@--ood.co.uk" />
  <domain name="*@---rs.co.uk" address="catch@--ood.co.uk" />
</config>

Coordinator
May 24, 2010 at 4:33 PM
Martyn,
The log file should be written to the same location as edgetransport.exe. (Most often there is no write permission to that directory for the Network Service Account, so you can add that permission temporarily.)
The domains need to be added to the accepted domain table yes. Otherwise SMTP will reject the RCPT TO commands.
I do see what you are doing wrong. All you need to enter is the domain name and not a regular expression:

<config>
<domain name="---el.co.uk" address="catch@--ood.co.uk" />
<domain name="---rs.co.uk" address="catch@--ood.co.uk" />
</config>

That's just like the provided example in the download:

<config>
<domain name="domain1.com" address="catchall@domain1.com" />
<domain name="domain2.com" address="admin@domain2.com" />
</config>

Wilbert

From: [email removed]
Sent: Monday, May 24, 2010 5:21 AM
Subject: Re: Need help!! Sbs 2008 and Exchange 2007 [catchallagent:213154]

From: martynpb

Willbertdg

config file as below, the emails need to catch everything from two domains and forward them through to the specified email address, do i need to add these domains in to the accepted domain on the exchange console? Or will this not be required, i have tried both ways.

tried to setup the logging, and cannot find where the log file goes to, or if its actually doing something!

Much Appreciated!

Martyn

<config>
<domain name="*@---el.co.uk" address="catch@--ood.co.uk" />
<domain name="*@---rs.co.uk" address="catch@--ood.co.uk" />
</config>